解决wordpress插件Crayon Syntax Highlighter在高版本PHP中报错问题.

😯 几年不登陆,一登陆就提示说我用的PHP不安全,得,您说的都对,我升级.问题来了.沙雕Crayon Syntax Highlighter插件几年没更新了,对高版本PHP支持有问题.具体表现如下.

这什么吊玩意.

看了下文件,初步估计应该是语法问题.在报错行加个转义符搞定.

文件位置:/wp-content/plugins/crayon-syntax-highlighter/crayon_langs.class.php

340行替换成下面这个

return preg_replace('/\[^\w-+#]/msi', '', $id);

如图:

这傻吊插件,得找个机会把他给换了.

转载请注明出处,多谢!
THE END
分享
二维码
< <上一篇
下一篇>>